• NesSoft
    0
    Hello,
    I installed the 40 amp Renogy DC to DC charger after watching a few you tube videos (including the one Ray did). It works great, however ... I installed a 60 amp circuit breaker in the engine compartment just like Ray did. That circuit breaker keeps popping. Some times it can go the whole drive (2-3 hours) without popping, other times it pops within an hour. I do not know what would be popping it. I wonder if it could be caused when I go up hill and the engine's RPMs go up? Any ideas?

    I have a 2009 F350 dually, with a 37' fifth wheel. Is there a way I can limit the amps from the battery to the circuit breaker?
  • Luc Francine
    0
    did you put an dc amp meter on the wire comming from the battery to the 60 amp breaker to see if the amperage was close to the 60 amp breaker value
  • Ray
    704
    I think what could be happening is the cable gauge may be too small for the run length. If the voltage drops a lot from the battery to the Renogy box it then has to increase the current draw to maintain the same power transfer.
    For example, if its output is 14.6V at 40 amps power equals 584 watts
    If the input is 12.3V then the amperage needs to be 47.5 amps
    If the input is 11.6 then the amperage draw needs to be 50.34 amps

    Figures are just for illustration but you can see how the voltage drop affects the input amperage draw. There will also be some losses from the unit itself via heat so the amperage would be higher. I find in my setup the draw is around 50 amps or so.

    Another thing that can affect the amperage is the battery and alternator. Maybe the batteries are on the older side and have degraded a bit in performance, ie. weak cells so can't hold the voltage as well or the alternator is varying in voltage. My alternator is what they call a smart alternator, with built-in regulation, so it will vary the voltage based on demand. Generally though when it sees the draw of the DC-DC charger it should raise its output to around 14.4.

    Cheers, Ray
  • NesSoft
    0
    Thanks Ray, I am using 4 gauge wire like the manual says, and brand new batteries (3 weeks old). I wonder if my alternator does not have generate enough amps? Do you think that could cause the issue, if it does not generate enough amperage? It looks like I could either have a 200 amp or a 125 amp. Not sure which one I have, so I will investigate that.
  • NesSoft
    0
    Thank you Luc, that is a good idea. However, my multimeter does not measure amps. I have been wanting to get one, I guess this is a good excuse to do so.
  • Ray
    704
    I'd guess it must be able to generate the amps if it is able to blow the breaker. I used 4 gauge as well. I'd want to check the voltage at the DC-DC chargers input terminals and the trucks battery terminals and see if there is an excessive voltage drop. I guess it could be a poor connection along the way but since you just installed, it not as likely. Might want to check at each connection on the path and see if any are much hotter than any of the others.
    I'd also want to use a check the actual amperage just to rule out a faulty breaker tripping for no reason.
  • NesSoft
    0
    OK, thanks. I just ordered the Digital Clamp Multimeter you have on your amazon page. My multimeter is old and very basic does not show amps, only volts and ohms.
bold
italic
underline
strike
code
quote
ulist
image
url
mention
reveal
youtube
tweet
Add a Comment