• Zenitrame
    7
    Hello all,
    Could really use your help please!

    I’m having an issue with my Dometic 15,000 AC. The AC will not start when the interior temp of the trailer is reading 100+. Happened right after arriving in Phoenix. I was setting up and it was very hot outside (112F) but the AC would not turn on. Ended up staying at a hotel until it cooled down to 98F. It has happened again this time while my trailer is parked at my house. I went to turn on the AC, but it would not kick on. The “In-Command” display was once again showing an internal temp of 100F. I thought it must be the In-Command not working but I am able to move the slide, turn on lights and extend the awning using the In-Command. Once the internal temp drops below 100F, the AC kicks on.

    Does the AC have a safety that keeps it from turning on? Is it an issue with the In-Command?

    Any help or suggestions would be greatly appreciated.

    Thanks in advance,
    Milo
  • Ray
    921
    That's a weird one that it would not work above 100F. I searched around the net and found this https://static.nhtsa.gov/odi/tsbs/2019/MC-10153026-9999.pdf Could be the problem since the failure above 100F
  • Zenitrame
    7
    thanks Ray. I’ll check with the local authorized Keystone Service company to see if they are aware of this and hopefully they can repair/replace the affected parts.
  • Chris Davidson
    0
    This is the same problem I am having, Thanks.
  • Lisa's RV Experience
    67
    Milo,
    I had a similar issues in Portland when it was 115 degrees. I have a 2018 Class A so the A/C is new(er). At just over 100 degrees the A/C just turned off. I was wondering, do you have soft-start on the A/C? I do and wondered if that was why the A/C turned off. I'm only 30amp so I guess I was more forgiving with the issue, but I did have to check into a hotel until about 11pm when it finally got below 95 degrees and the A/C worked.

    Lisa
  • Zenitrame
    7
    Just an update and answers to some questions. I did have the SoftStart installed however, the ac issues were happening before the SoftStart was installed AND continued after the installation. Ray provided some very helpful information above. I provided that information to my local/authorized Keystone Service dealer. They were not aware of the issues occurring with some ACs. So, they asked if I could take my TT to their location so they could get some numbers off of the “gateway” installed on the AC. They had a list of the affected AC gateways. Mine was NOT on the list. They said it was off by one number. So they are going to contact Keystone to see if the one I have is eligible for replacement.

    I suggest downloading the link Ray provided and contact an authorized service dealer for your TT’s AC.

    I’ll let you know what they say about getting it replaced.

    Thanks again Ray.

    Milo
  • Ray
    921
    Thanks for the update. I can add that this summer we had abnormally high temps for these parts as high as 104.5F and our 10-year-old Coleman Mach 3 AC didn't miss a beat. So something must be wrong.
  • Zenitrame
    7
    Hello all,
    Just another update on the above mentioned issue. So Keystone told the local authorized service company that my AC’s gateway was NOT part of the recall/service. They suggested updating the software on the iN-Command monitor and that it may resolve the issue. So I went to the iN-Command website (https://in-command.net/) downloaded the latest software (mine was several versions too old). Took the thumb drive to the monitor and loaded it. iN-Command has very good instructions on how to do all this. Anyway, the temps have not been high so I don’t know yet if the software update corrected the problem. Have to wait for it to get hot around here. However, the update did create a new issue: I can no longer connect to it via Bluetooth to any devices. Anyway, iN-Command instructed me to send the monitor to them so they can test it. If there is an actual defect they will replace it and if not, they will return it as is. Not functions properly.

    Sorry for the long update but I thought it might help out some.

    Milo

    https://in-command.net/
  • Chris Davidson
    0
    Thank you Zenitrame
bold
italic
underline
strike
code
quote
ulist
image
url
mention
reveal
youtube
tweet
Add a Comment